Jump to content

 
Photo

Undefined z value in DEM

- - - - -

  • Please log in to reply
6 replies to this topic

#1
logistics

logistics

    Newbie

  • Validated Member
  • Pip
  • 4 posts
  • United Kingdom

Hello, wonder if anyone could help me out.

I've got a DEM with a cell size of 15m and I am trying to use it calculate slope angle in ArcGIS 10.0. However the problem I'm having is the Z value is undefined. I have tried using the default 1 and attempted a conversion from feet using 0.3048 both outputs result in giving just two values 0 and the max height. I'm pretty new to all this so I'm quite sure what else to try? I've done this kind of analysis before with no problems, but this DEM is from a different source.

The spatial reference is GCS_WGS_1984 if this helps.

Thanks in advance

#2
David Medeiros

David Medeiros

    Hall of Fame

  • Validated Member
  • PipPipPipPipPipPipPip
  • 1,085 posts
  • Gender:Male
  • Location:Redwood City CA
  • Interests:Cartography, wood working, wooden boats, fishing, camping, overland travel, exploring.
  • United States

Hello, wonder if anyone could help me out.

I've got a DEM with a cell size of 15m and I am trying to use it calculate slope angle in ArcGIS 10.0. However the problem I'm having is the Z value is undefined. I have tried using the default 1 and attempted a conversion from feet using 0.3048 both outputs result in giving just two values 0 and the max height. I'm pretty new to all this so I'm quite sure what else to try? I've done this kind of analysis before with no problems, but this DEM is from a different source.

The spatial reference is GCS_WGS_1984 if this helps.

Thanks in advance


It would be best to project the DEM first, from WGS 84 so something in meters. Then try both z values again, 1 & .3048 (although chances are its z values are in meters). Where is the DEM from?

GIS Reference and Instruction Specialist, Stanford Geospatial Center.

 

www.mapbliss.com

 


#3
logistics

logistics

    Newbie

  • Validated Member
  • Pip
  • 4 posts
  • United Kingdom

It would be best to project the DEM first, from WGS 84 so something in meters. Then try both z values again, 1 & .3048 (although chances are its z values are in meters). Where is the DEM from?


I tried changing the coordinate system to GCS_OSGB_1936 which is meters and also the same as my data frame and the rest of my layers. This however sent it zooming off to the other side of the world and Slope analysis gave the same results - I did not receive a warning about the Z values this time though. It's as if the DEM doesn't contain any elevation data, yet I can classify it just fine.

The DEM is from http://gdem.ersdac.j...or.jp/index.jsp

#4
David Medeiros

David Medeiros

    Hall of Fame

  • Validated Member
  • PipPipPipPipPipPipPip
  • 1,085 posts
  • Gender:Male
  • Location:Redwood City CA
  • Interests:Cartography, wood working, wooden boats, fishing, camping, overland travel, exploring.
  • United States

It would be best to project the DEM first, from WGS 84 so something in meters. Then try both z values again, 1 & .3048 (although chances are its z values are in meters). Where is the DEM from?


I tried changing the coordinate system to GCS_OSGB_1936 which is meters and also the same as my data frame and the rest of my layers. This however sent it zooming off to the other side of the world and Slope analysis gave the same results - I did not receive a warning about the Z values this time though. It's as if the DEM doesn't contain any elevation data, yet I can classify it just fine.

The DEM is from http://gdem.ersdac.j...or.jp/index.jsp


ASTER Z units are definitely in meters. Not sure what GCS_OSGB_1936 is. Obviously ordinance survey, but is that the projection or just the reference system and datum? GCS stands for geographic coordinate system, so that would not be in meters if the projection.

My suggestion would be to project the DEM into something less obscure, more regional, to do the slope calculations. Make sure you reset the mxd data frame projection after re projecting the DEM. Then re project the resulting slope raster to your GCS_OSGB_1936 so you can add it to the rest of your work.

Also, make sure you are using the Project Raster tool, not Define Projection. Having the raster shoot off into space after "projecting" sounds like a misuse of the Define tool. Let me know if any of that helps.

GIS Reference and Instruction Specialist, Stanford Geospatial Center.

 

www.mapbliss.com

 


#5
logistics

logistics

    Newbie

  • Validated Member
  • Pip
  • 4 posts
  • United Kingdom

It would be best to project the DEM first, from WGS 84 so something in meters. Then try both z values again, 1 & .3048 (although chances are its z values are in meters). Where is the DEM from?


I tried changing the coordinate system to GCS_OSGB_1936 which is meters and also the same as my data frame and the rest of my layers. This however sent it zooming off to the other side of the world and Slope analysis gave the same results - I did not receive a warning about the Z values this time though. It's as if the DEM doesn't contain any elevation data, yet I can classify it just fine.

The DEM is from http://gdem.ersdac.j...or.jp/index.jsp


ASTER Z units are definitely in meters. Not sure what GCS_OSGB_1936 is. Obviously ordinance survey, but is that the projection or just the reference system and datum? GCS stands for geographic coordinate system, so that would not be in meters if the projection.

My suggestion would be to project the DEM into something less obscure, more regional, to do the slope calculations. Make sure you reset the mxd data frame projection after re projecting the DEM. Then re project the resulting slope raster to your GCS_OSGB_1936 so you can add it to the rest of your work.

Also, make sure you are using the Project Raster tool, not Define Projection. Having the raster shoot off into space after "projecting" sounds like a misuse of the Define tool. Let me know if any of that helps.


Sorry I wasn't clear on that. The projection is british national grid, both for the data frame and DEM. The coordinate system is GCS_OSGB_1936. I'm still getting the same results. I'm finishing work now but tomorrow I shall post some screenshots to see if that will help explain the situation!

#6
DaveB

DaveB

    Hall of Fame

  • Validated Member
  • PipPipPipPipPipPipPip
  • 1,054 posts
  • Gender:Not Telling
  • Location:Redlands, CA
  • United States

From some ArcGIS documentation:

If the input raster is in a spherical coordinate system, such as decimal degrees, the results from Hillshade may look peculiar. This is due to the difference in measure between the horizontal ground units and the elevation z units. Since the length of a degree of longitude changes with latitude, you will need to specify an appropriate z-factor for that latitude. If your x,y units are decimal degrees and your z units are meters, some appropriate z factor for particular latitudes are:

Latitude Z-factor
0 0.00000898
10 0.00000912
20 0.00000956
30 0.00001036
40 0.00001171
50 0.00001395
60 0.00001792
70 0.00002619
80 0.00005156


For more info see this blog entry about setting the z-factor.
Dave Barnes
Esri
Product Engineer
Map Geek

#7
logistics

logistics

    Newbie

  • Validated Member
  • Pip
  • 4 posts
  • United Kingdom

I believe I've solved the problem - which of course was a stupidly simple solution - I needed to select a Z coordinate system not just the x y unsurprisingly :huh: though I've never had to do that before. Funny how a new day can make such a difference, don't know how I failed to notice the Z coordinate tab :D

Thank you for the help and patience!

Edited by logistics, 30 November 2012 - 05:25 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->