Jump to content

 
Photo

Hill shade dark

- - - - -

  • Please log in to reply
4 replies to this topic

#1
razornole

razornole

    Legendary Contributor

  • Validated Member
  • PipPipPipPipPip
  • 452 posts
  • Gender:Male
  • Location:Ozark Plateau, Arkansas
  • Interests:Photography, Cartography, Down-river canoeing, Backpacking, Cross country biking, Geomorphology, Ornithology, Ecology, Quaternary, and last but first; drinking beer on the beach.
  • United States

Does anyone know why in ArcMap 10 my hillshade gets excessively dark in my mxd file if I remove it and bring it back into the mxd?

When I create the hillshade everything looks fine. If I save the mxd file and open it again everything sill looks fine, but as I mentioned above if I remove it from the mxd and bring it back in that is when gets dark. See attached files of the same hillshade. The light one is before I remove and the dark after I bring it back in to my mxd file.

I'm in a geographic coordinate system and I created the hillshade with the correct z factor.

I didn't have this problem in 9.3.

Thanks,
kru

Attached Files


"Ah, to see the world with the eyes of the gods is geography--to know cities and tribes, mountains and rivers, earth and sea, this is our gift."
Strabo 22AD

#2
Zorko

Zorko

    Contributor

  • Validated Member
  • PipPip
  • 11 posts
  • Gender:Male
  • Location:Auckland
  • New Zealand

Does anyone know why in ArcMap 10 my hillshade gets excessively dark in my mxd file if I remove it and bring it back into the mxd?

When I create the hillshade everything looks fine. If I save the mxd file and open it again everything sill looks fine, but as I mentioned above if I remove it from the mxd and bring it back in that is when gets dark. See attached files of the same hillshade. The light one is before I remove and the dark after I bring it back in to my mxd file.

I'm in a geographic coordinate system and I created the hillshade with the correct z factor.

I didn't have this problem in 9.3.

Thanks,
kru


Hi,

Did you check what is defined as default strech type? In ArcMap 10.1 you can define it in ArcMap Options, Raster tab, Raster layer if you activate 'Enable Custom Rendering Defaults'.

Regards,
Zorko

#3
SaultDon

SaultDon

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 153 posts
  • Gender:Male
  • Location:BC
  • Interests:Environmental/Wildlife GIS, Aboriginal Land Use and Occupancy
  • Canada

Does anyone know why in ArcMap 10 my hillshade gets excessively dark in my mxd file if I remove it and bring it back into the mxd?


When you bring the raster back into ArcMAP and it's all dark, open it's properties and check the Symbology tab.

One thing to check off the bat is the stretch type.

Change Type: under Stretch to either None or Minimum-Maximum and see if that works.

Sometimes the stretch type can default to something else like Std. Dev. instead of None.

I don't know why.. it could be choosing the stretch type when it looks at the statistics generated for the image (if the statistics exist...).

#4
razornole

razornole

    Legendary Contributor

  • Validated Member
  • PipPipPipPipPip
  • 452 posts
  • Gender:Male
  • Location:Ozark Plateau, Arkansas
  • Interests:Photography, Cartography, Down-river canoeing, Backpacking, Cross country biking, Geomorphology, Ornithology, Ecology, Quaternary, and last but first; drinking beer on the beach.
  • United States

Does anyone know why in ArcMap 10 my hillshade gets excessively dark in my mxd file if I remove it and bring it back into the mxd?


When you bring the raster back into ArcMAP and it's all dark, open it's properties and check the Symbology tab.

One thing to check off the bat is the stretch type.

Change Type: under Stretch to either None or Minimum-Maximum and see if that works.

Sometimes the stretch type can default to something else like Std. Dev. instead of None.

I don't know why.. it could be choosing the stretch type when it looks at the statistics generated for the image (if the statistics exist...).


That was the problem I figured it was something simple. It was defaulting to Standard Deviations.

Thanks a lot,
kru
"Ah, to see the world with the eyes of the gods is geography--to know cities and tribes, mountains and rivers, earth and sea, this is our gift."
Strabo 22AD

#5
frax

frax

    Hall of Fame

  • Associate Admin
  • PipPipPipPipPipPipPip
  • 2,312 posts
  • Gender:Male
  • Location:Stockholm, Sweden
  • Interests:music, hiking, friends, nature, photography, traveling. and maps!
  • Sweden

I would recommend setting the default to None!
Hugo Ahlenius
Nordpil - custom maps and GIS
http://nordpil.com/
Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->