Jump to content

 
Photo

Need help for Creating DTM

- - - - -

  • Please log in to reply
10 replies to this topic

#1
Anand

Anand

    Contributor

  • Validated Member
  • PipPip
  • 15 posts
  • United Kingdom

Can someone create or help me to create the DTM using these ground elevation(Z) values provided in attachment please? I don't have and know the specific software that needs to be used to create DTM. It seems the software for it is quite expensive. Anyway the grid size(spacing in both direction evenly) is 1000m. DTM needs to be ASCII(.asc) file format. I'm using ISIS 2D simulation in case you want to know it.
Your feedback is appreciated.

Attached Files



#2
frax

frax

    Hall of Fame

  • Associate Admin
  • PipPipPipPipPipPipPip
  • 2,301 posts
  • Gender:Male
  • Location:Stockholm, Sweden
  • Interests:music, hiking, friends, nature, photography, traveling. and maps!
  • Sweden

It is actually quite easy to make into an ArcGIS ascii file. You just need to add the header as specified here: http://en.wikipedia....Esri_grid#ASCII. And remove some extra spaces that you had in the file. Is 100.0 = NODATA? Then you need to add it to the header. Since you don't provide any geographic reference, then you would have to either punch that into the header or reference it afterwards (so that the coords are in a proper coordinate system).

See attachment...
Attached File  topo.zip   1.02KB   11 downloads
Hugo Ahlenius
Nordpil - custom maps and GIS
http://nordpil.com/
Twitter

#3
Anand

Anand

    Contributor

  • Validated Member
  • PipPip
  • 15 posts
  • United Kingdom

It is actually quite easy to make into an ArcGIS ascii file. You just need to add the header as specified here: http://en.wikipedia....Esri_grid#ASCII. And remove some extra spaces that you had in the file. Is 100.0 = NODATA? Then you need to add it to the header. Since you don't provide any geographic reference, then you would have to either punch that into the header or reference it afterwards (so that the coords are in a proper coordinate system).

See attachment...
Attached File  topo.zip   1.02KB   11 downloads

Thank you for your help. Yeah 100=no data. Sorry for asking but can the map be in higher resolution?

#4
Anand

Anand

    Contributor

  • Validated Member
  • PipPip
  • 15 posts
  • United Kingdom

Hi Frax
I finally got ArcGIS 10 Demo version and did what you recommended to me. Now the thing is I don't know how to change the file type. It is now ESRI ArcMap Document (.mxd). I need to change it into .asc.

#5
J Wallace

J Wallace

    Contributor

  • Validated Member
  • PipPip
  • 11 posts
  • United States

Hi Frax
I finally got ArcGIS 10 Demo version and did what you recommended to me. Now the thing is I don't know how to change the file type. It is now ESRI ArcMap Document (.mxd). I need to change it into .asc.


Anand -
The .mxd file is ESRI's proprietary map document format - it is the file extension used for the ArcMap project that you are working with your data in. The raster data that you are specifically interested in is most likely saved as .grd (Arc's native raster format). To convert your data to ascii, open the .mxd project, open Arc Toolbox, and select Conversion Tools - From Raster - Raster to ASCII. This should give you a .asc output.

#6
Anand

Anand

    Contributor

  • Validated Member
  • PipPip
  • 15 posts
  • United Kingdom

Hi Frax
I finally got ArcGIS 10 Demo version and did what you recommended to me. Now the thing is I don't know how to change the file type. It is now ESRI ArcMap Document (.mxd). I need to change it into .asc.


Anand -
The .mxd file is ESRI's proprietary map document format - it is the file extension used for the ArcMap project that you are working with your data in. The raster data that you are specifically interested in is most likely saved as .grd (Arc's native raster format). To convert your data to ascii, open the .mxd project, open Arc Toolbox, and select Conversion Tools - From Raster - Raster to ASCII. This should give you a .asc output.

Wallace
I have tried it before but when I try to choose input raster, the .mxd map file doesn't show up.

#7
J Wallace

J Wallace

    Contributor

  • Validated Member
  • PipPip
  • 11 posts
  • United States

Hi Frax
I finally got ArcGIS 10 Demo version and did what you recommended to me. Now the thing is I don't know how to change the file type. It is now ESRI ArcMap Document (.mxd). I need to change it into .asc.


Anand -
The .mxd file is ESRI's proprietary map document format - it is the file extension used for the ArcMap project that you are working with your data in. The raster data that you are specifically interested in is most likely saved as .grd (Arc's native raster format). To convert your data to ascii, open the .mxd project, open Arc Toolbox, and select Conversion Tools - From Raster - Raster to ASCII. This should give you a .asc output.

Wallace
I have tried it before but when I try to choose input raster, the .mxd map file doesn't show up.


Anand- the .mxd is not your raster, it is only the project that your raster is currently saved in. When you open the .mxd, the raster dataset will appear as a layer in the ArcMap table of contents that can be turned off and on. If you open the conversion tool directly from ArcMap, you should be able to drag this layer from the project directly into the tool dialog box. If this doesn't work, right-click on your raster layer in ArcMap, select Export , and try exporting your data to a new location (preferably a file path with no spaces in it). This file will be the one that you need to work with, not the .mxd.

#8
Anand

Anand

    Contributor

  • Validated Member
  • PipPip
  • 15 posts
  • United Kingdom

Hi Frax
I finally got ArcGIS 10 Demo version and did what you recommended to me. Now the thing is I don't know how to change the file type. It is now ESRI ArcMap Document (.mxd). I need to change it into .asc.


Anand -
The .mxd file is ESRI's proprietary map document format - it is the file extension used for the ArcMap project that you are working with your data in. The raster data that you are specifically interested in is most likely saved as .grd (Arc's native raster format). To convert your data to ascii, open the .mxd project, open Arc Toolbox, and select Conversion Tools - From Raster - Raster to ASCII. This should give you a .asc output.

Wallace
I have tried it before but when I try to choose input raster, the .mxd map file doesn't show up.


Anand- the .mxd is not your raster, it is only the project that your raster is currently saved in. When you open the .mxd, the raster dataset will appear as a layer in the ArcMap table of contents that can be turned off and on. If you open the conversion tool directly from ArcMap, you should be able to drag this layer from the project directly into the tool dialog box. If this doesn't work, right-click on your raster layer in ArcMap, select Export , and try exporting your data to a new location (preferably a file path with no spaces in it). This file will be the one that you need to work with, not the .mxd.

It's works I saved as a layer file. Now the thing is I need to make it into DTM with .asc extension. Because when I do conversion from raster to ASCII, it becomes .txt file. ISIS Mapper doesn't recognise .txt. It needs to be .asc like the one uploaded by Frax (see attachment).

#9
J Wallace

J Wallace

    Contributor

  • Validated Member
  • PipPip
  • 11 posts
  • United States

[/quote]
It's works I saved as a layer file. Now the thing is I need to make it into DTM with .asc extension. Because when I do conversion from raster to ASCII, it becomes .txt file. ISIS Mapper doesn't recognise .txt. It needs to be .asc like the one uploaded by Frax (see attachment).
[/quote]

Someone else with some ISIS Mapper experience (as in, more than none) may have a better solution, but if the header information is right, you should be able to just manually rename the file extension from .txt to .asc...

#10
Anand

Anand

    Contributor

  • Validated Member
  • PipPip
  • 15 posts
  • United Kingdom

Someone else with some ISIS Mapper experience (as in, more than none) may have a better solution, but if the header information is right, you should be able to just manually rename the file extension from .txt to .asc...
[/quote]

I believe the header is correct. How can I change it manually?

#11
Anand

Anand

    Contributor

  • Validated Member
  • PipPip
  • 15 posts
  • United Kingdom

Okay finally done! :lol:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->