Jump to content

 
Photo

Sluggish Performance - Illustrator CS5

- - - - -

  • Please log in to reply
5 replies to this topic

#1
liz1110

liz1110

    Contributor

  • Validated Member
  • PipPip
  • 20 posts
  • Location:Orlando, FL
  • United States

I'm working on a 24"x36" topographic map in Illustrator CS5. The file is approximately 60 MB in size and has about 30-40 layers. There are four different road layers, each with a graphic style applied to create cased lines. I also have layers with hydrologic features, contours, trails and all sorts of labels. The bottom layer in the stack is a shaded relief background.

I am finding that Illustrator has slowed to a crawl and it is becoming frustrating to work on my map because it takes forever to do simple tasks like selecting and moving text, panning and zooming. I have tried turning off and locking the layers that I am not using but it doesn't seem to help at all. I just recently completed a series of similar maps that were smaller (11"x17") but they had just as many layers and the file size was around 40 MB and I had no performance issues while working on them. I'm at my wit's end trying to figure out what the problem is with this particular file.

I'm working on a Mac running OS 10.6.8 with a 3.06 GHz processor and 8 GB of RAM. The data was exported from Manifold as .ai file with resolution set at 360 dpi.

Any suggestions or solutions to the problem will be greatly appreciated.
Liz Cruz

#2
Tim Stallmann

Tim Stallmann

    Contributor

  • Validated Member
  • PipPip
  • 18 posts
  • Location:Durham, NC, USA
  • United States

Liz -- In situations like this I've had some luck putting some of the more background layers into a separate AI file and then placing that file as an object into the master AI file.. that should help some since illustrator will pre-render those layers rather than rendering them newly each time...

#3
David Medeiros

David Medeiros

    Hall of Fame

  • Validated Member
  • PipPipPipPipPipPipPip
  • 1,063 posts
  • Gender:Male
  • Location:Redwood City CA
  • Interests:Cartography, wood working, wooden boats, fishing, camping, overland travel, exploring.
  • United States

You could try turning off the thumbnails in the layers palette. They seem to increase redraw times (at least in CS4). Do you link or embed the raster layers (shaded relief)? Embedding increases file size and may also slow down performance, not sure on that though. If you have a lot of line layers like the roads and rivers and these came over as GIS data you may have way more vertices than needed, run the simplify filter at 99% or 98% to reduce complexity without sacrificing any line accuracy. If you have a lot of type, especially type on a path, this can slow things down, but no real solution there. When saving the file, turn off PDF compatibility to reduce the file size. Do you have a lot of clipping masks? That's another performance killer. So are a lot of special filter effects like drop shadows, inner glows etc. I usually wait until the end of the map to apply styles like these to prevent the redraw delays they bring.

Where did your data come from? How did you get it into AI? I have found that some import methods cause Illy to choke regardless of the data size. Bringing info in from PDF exports of either Arc or GeoMEdia (but especially GeoMedia) can cause performance issues.

On a curent map project working with typical topographic map layers I have found that my contour layer is the worst offender due to the huge number of vertices and bezier curves. Turning that layer alone off while editing makes a big performance diff. Give that a try.

Good luck.

GIS Reference and Instruction Specialist, Stanford Geospatial Center.

 

www.mapbliss.com

 


#4
liz1110

liz1110

    Contributor

  • Validated Member
  • PipPip
  • 20 posts
  • Location:Orlando, FL
  • United States

Liz -- In situations like this I've had some luck putting some of the more background layers into a separate AI file and then placing that file as an object into the master AI file.. that should help some since illustrator will pre-render those layers rather than rendering them newly each time...


Tim,

I moved my shaded relief background into a separate AI file as you suggested and immediately reduced the size of my master file down to a more manageable 40 MB. The performance has improved considerably as well. I didn't add the background back into the master as an object though. I'll wait until I am done with the map since I don't need that layer at all except for the finished printed product.

Thanks so much for your extremely helpful suggestion!
Liz Cruz

#5
liz1110

liz1110

    Contributor

  • Validated Member
  • PipPip
  • 20 posts
  • Location:Orlando, FL
  • United States

You could try turning off the thumbnails in the layers palette. They seem to increase redraw times (at least in CS4). Do you link or embed the raster layers (shaded relief)? Embedding increases file size and may also slow down performance, not sure on that though. If you have a lot of line layers like the roads and rivers and these came over as GIS data you may have way more vertices than needed, run the simplify filter at 99% or 98% to reduce complexity without sacrificing any line accuracy. If you have a lot of type, especially type on a path, this can slow things down, but no real solution there. When saving the file, turn off PDF compatibility to reduce the file size. Do you have a lot of clipping masks? That's another performance killer. So are a lot of special filter effects like drop shadows, inner glows etc. I usually wait until the end of the map to apply styles like these to prevent the redraw delays they bring.

Where did your data come from? How did you get it into AI? I have found that some import methods cause Illy to choke regardless of the data size. Bringing info in from PDF exports of either Arc or GeoMEdia (but especially GeoMedia) can cause performance issues.

On a curent map project working with typical topographic map layers I have found that my contour layer is the worst offender due to the huge number of vertices and bezier curves. Turning that layer alone off while editing makes a big performance diff. Give that a try.

Good luck.


David,

In addition to removing the shaded relief background to a separate AI file and linking it as Tim also suggested, I took your advice and turned off the thumbnails in the layers palette. It helped just slightly, but not enough, so I ran the simplify command on my hydro, road and contour layers. I was amazed at the number of vertices that were eliminated, especially from the hydro and contour layers. I don't have any type on a path (yet) but I do have a lot of clipping masks but I have achieved such great performance gains from the suggestions that I have already implemented that I should be able to work in the file without frustration and I will let the clipping masks stay for now. But, if things slow down again that will give me something else to try.

I really appreciate your suggestions. I am still a bit of a newbie with AI and the program is so complex I just had no idea what to do. Thanks again for your help!
Liz Cruz

#6
Scro

Scro

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Gender:Male
  • United States

I, too, have his problem. Along with the simplification method mentioned, you can also hide other artwork that you may not be working with at the moment. Simply select all the features in a certain area, choose Select > Inverse, then Object>hide>selection. This will dramatically speed up the program as it will not be re-drawing those features.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->