Jump to content

 
Photo

ArcGIS BLOB Field

- - - - -

  • Please log in to reply
2 replies to this topic

#1
NSBuhwheat

NSBuhwheat

    Contributor

  • Validated Member
  • PipPip
  • 30 posts
  • Gender:Male
  • Location:Sydney, Nova Scotia, Canada
  • Canada

Hi All,

I have a building poly layer in ARC SDE (9.3.1) running on SQL 2008. The server O\S is Windows Server 2003. What I have done, before giving a whole lot of thought, was to add a series of BLOB field (6 of them, to be precise), so that I can add photos to this structure file. Going the RASTER field route would limit you to one field, hence the BLOB. Not having used a BLOB field before, I have run into a problem, in that storing and retrieving information to BLOB fields requires customization or third party tools to load/view items in this field.

To be honest, I feel a bit let down by ESRI, in that I was expecting to be able to be up and running with this project.

Would anyone have any suggestions\recommendations so that I’d be able to work with these BLOB fields? I guess another option would be to store the path of the photo, which I had done in that past when we were using shapefiles, but I’d use that as a last resort.

Thanks in advance,


Jamie Whitters
BLOB Challenged

#2
frax

frax

    Hall of Fame

  • Associate Admin
  • PipPipPipPipPipPipPip
  • 2,320 posts
  • Gender:Male
  • Location:Stockholm, Sweden
  • Interests:music, hiking, friends, nature, photography, traveling. and maps!
  • Sweden

So you want to easily interact and display the photos in the BLOBS through ArcMap?
Hugo Ahlenius
Nordpil - custom maps and GIS
http://nordpil.com/
Twitter

#3
NSBuhwheat

NSBuhwheat

    Contributor

  • Validated Member
  • PipPip
  • 30 posts
  • Gender:Male
  • Location:Sydney, Nova Scotia, Canada
  • Canada

So you want to easily interact and display the photos in the BLOBS through ArcMap?


Hello Hugo,

That was my plan, but info from ESRI Redlands, via my LinkedIn account, has brought to light a new feature in 10 that is available. It is called Attachments, and a cursory read of the features indicate is should have all the capability that I need, plus more. The only fly in the ointment is that we are still running the 9.3.1 version of SDE, and for the new feature to work, it requires SDE to be at 10, also. The upgrade is planned, but I may have to wait for a few months before it takes place.

Have been assured by ESRI tech support that Attachments will work with a Desktop 10\SDE 10 match, so I don't mind the wait.

All the best from Cape Breton, NS.

Cheers,




Jamie Whitters




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->