Jump to content

 
Photo

Projection transformation: shapefile and raster file behave differently

- - - - -

  • Please log in to reply
1 reply to this topic

#1
darkspider

darkspider

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Uganda

Hi everybody,
I've done a lot of research, but couldn't find a solution to my problem. Maybe you guys have an idea:

I have problems with using Arc1960 projections in WGS1984 (data frame and base maps are WGS1984). The thing is that I have Arc1960 GPS coordinates, which I plot in Arc1960 and convert them with the toolbox Data Management> Projections and Transformations-> feature-> Project. Then they are correctly plotted. Alternatively, I can set any transformation rather than none (X = 0, Y = 0, Z = 0) in the Data Frame Properties to get a correct plotting on-the-fly. But now it comes:

Working with raster data that does not work similar, it behaves exactly the other way. I'm doing scans of topographic maps and geo-reference them with Arc1960. I insert them into my project where the transformation in the data frame settings is setted as a standard transformation. The scan is shown shifted by about 300m on-the-fly. Using a transformation of 0 (X, Y, Z) it is plotted at the correct position (but my Arc1960 GPS points not anymore. Does not matter though, I could theoretically live with the fact that I transform with X, Z, Y = 0 in the data frame and convert my feature classes simply with the toolbox). But why should I not convert my raster data but my shapefiles?

Of course, I've also tried to convert the raster data (same toolbox, rather than only feature I suppose, "grid" -> "Project Raster"). My grid was moved but not at the correct position.

From the theoretical side, everything with a different projection from the data frame should be converted, right? Actually, I'm assuming this, but for all data, whether raster or GPS coordinates.

Does anyone have any idea what is going wrong here?

#2
AndyM

AndyM

    Key Contributor

  • Validated Member
  • PipPipPip
  • 56 posts
  • Location:Ottawa
  • Canada

I don't completely understand the problem, and you may already have tried this, but ...

I seem to remember reading that GRID is considered to be an ArcInfo format and uses the old projection engine. If you are still struggling with this, it might be worth trying to convert the raster to a different format (like img?) and trying again.

I know the "old" projection engine ignored datums for some projections, and that ArcGIS now deals with them better.

Good luck!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->