Jump to content

 
Photo

Geodatabase and Arcinfo coverage question

- - - - -

  • Please log in to reply
4 replies to this topic

#1
Robert2009

Robert2009

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 122 posts
  • Gender:Male
  • Location:Las Cruces, NM
  • United States

Have a question. Here I have a data that has polygons and when I did QA/QC on it, the topology does not detect any slivers or gaps. When I export it to coverage as a region and then build labels. The labels indicted that there are slivers and gaps in it. I am wondering how do I correct them ?

The geodatabase topology was set to 0.001 and set the rules as Must not overlaps and Must not have gaps.
Should I clean them in coverage and at what tolerance should I set to ?

I am using ArcGIS 9.2 SP6.

Please advice ?

#2
dsl

dsl

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 225 posts
  • Gender:Male
  • Location:Denver
  • United States

Sometimes these slivers come from polygons that intersect themselves. I've found that to be the case with poor digitizing, or data that I've downloaded. I think geodatabase has a do not self-intersect option. Since you already have it in a coverage, then this is what I've done in the past. ArcGIS doesn't let you edit the coverage directly, and I'm not familiar enough with ArcInfo workstation to do this. Assuming your original file has a unique identifier column, convert the coverage back to a geodatabase or shapefile. Run statistics on the unique ID column so that you a count of each id. Most ids will have a count of 1, but the ones that have slivers will have a count greater than one. Then you can idenitify the problem polygons, and where they are. This probably only works really if you have a few dozen problems or less.

Cheers,
David

#3
Robert2009

Robert2009

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 122 posts
  • Gender:Male
  • Location:Las Cruces, NM
  • United States

Yeah, I think I forgot to mention that it was originally in polylines and apparently the digitizer may have forgotten to set the snap on to the layer they need to set to. I think that is probably why that cause the slivers or gaps to go undetected. The geodatabase topology I set to is 0.001. Should I export to arc coverage and clean it to fix them ? At what tolarance should I need to fix them ?

#4
Robert2009

Robert2009

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 122 posts
  • Gender:Male
  • Location:Las Cruces, NM
  • United States

Problem solved !

#5
Sv_BG

Sv_BG

    Contributor

  • Validated Member
  • PipPip
  • 33 posts
  • Gender:Male
  • Location:Sofia
  • Bulgaria

Did the clean procedure in workstation help?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->