Jump to content

 
Photo

EOO File

- - - - -

  • Please log in to reply
12 replies to this topic

#1
David25

David25

    Key Contributor

  • Validated Member
  • PipPipPip
  • 70 posts
  • Gender:Male
  • Location:Calgary
  • Canada

Hi all,

I have found a so-called EOO file that I would like to use here: http://nrdata.nps.go.../glac_peaks.e00

It's a list of mountain peaks in Glacier Park, MT.

Anyway, when clicked on from the website that is what I can see. My question is, what to do with it??? I'm not sure how I should be saving it. I eventually want it as a shapefile.

Any help would be appreciated.

Thanks.

#2
Hans van der Maarel

Hans van der Maarel

    CartoTalk Editor-in-Chief

  • Admin
  • PipPipPipPipPipPipPip
  • 3,860 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Cartography, GIS, history, popular science, music.
  • Netherlands

E00 is ArcInfo Export. You can open it in most GIS applications that can handle shapefiles. What software do you have at your disposal?
Hans van der Maarel - Cartotalk Editor
Red Geographics
Email: hans@redgeographics.com / Twitter: @redgeographics

#3
David25

David25

    Key Contributor

  • Validated Member
  • PipPipPip
  • 70 posts
  • Gender:Male
  • Location:Calgary
  • Canada

E00 is ArcInfo Export. You can open it in most GIS applications that can handle shapefiles. What software do you have at your disposal?


I have ArcGIS 9.3

When added as a text file (which is what I saved it as) I cannot display XY data as there are no column headings. And the numbers don't even look like coordinates.

When I am viewed with all that text (from I link I posted) what should be my next step?

Thanks

#4
BioGeoMan

BioGeoMan

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 188 posts
  • Gender:Male
  • Location:Albuquerque, NM
  • United States

Try the Import71 Utility. I think you can go to the ESRI site and download the utility there, or there may be other sites on the web as well.

M.

Michael Scisco

BioGeoCreations
Albuquerque, NM

505-603-3636
biogeocreations.com


#5
David25

David25

    Key Contributor

  • Validated Member
  • PipPipPip
  • 70 posts
  • Gender:Male
  • Location:Calgary
  • Canada

Try the Import71 Utility. I think you can go to the ESRI site and download the utility there, or there may be other sites on the web as well.

M.


Thanks, I did try that but no luck. As soon as I click that link and see that text that's as far as I can get. If that is the E00 file then how do I save it? I tried Import71 but the input has to be e00 and I haven't got that far yet. It looks like a .txt file when opened.....but isn't......

#6
oldtoby

oldtoby

    Contributor

  • Validated Member
  • PipPip
  • 37 posts
  • United States

Well I think your problem is you saved it as a text file.

Save the file to your computer as glac_peaks.e00 , which is what it should default to when you click the link.

then use the Import71 utility which will convert it to an ARCGIS coverage shapefile.

#7
Bryan Swindell

Bryan Swindell

    Contributor

  • Validated Member
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Montana
  • United States

Open up ArcCatalog. Go to View > Toolbars > ArcView 8x Tools. This will activate the Coversion Tools button on your toolbar. Select Import from Interchange File... and away you go. Note, you must be sure that none of your directory folder names are too long (too many characters).

#8
christine.skl

christine.skl

    Key Contributor

  • Validated Member
  • PipPipPip
  • 62 posts
  • Gender:Female
  • Location:Hangzhou, China
  • Interests:Cartography, GIS, Travel, Books, Music
  • China

Thanks, I did try that but no luck. As soon as I click that link and see that text that's as far as I can get. If that is the E00 file then how do I save it? I tried Import71 but the input has to be e00 and I haven't got that far yet. It looks like a .txt file when opened.....but isn't......


Hmmm....maybe just right click on the link, choose "save as" . Or, if it opens in Notepad, choose "save as", in the dialog box choose "*.*" format option and type in the desired format. Otherwise Get Notepad ++ which won't mess up file extensions. I think this might be your problem...
Christine

#9
KimWright

KimWright

    Key Contributor

  • Validated Member
  • PipPipPip
  • 67 posts
  • Gender:Male
  • Location:Brisbane
  • Australia

Yes, I would agree with Christine. I right-clicked on your linked and saved the file and it opened with no problem in GlobalMapper showing the locations and names of the peaks.
Kim Wright
MAPgraphics, Brisbane, Australia
www.mapgraphics.com.au

#10
David25

David25

    Key Contributor

  • Validated Member
  • PipPipPip
  • 70 posts
  • Gender:Male
  • Location:Calgary
  • Canada

Thanks for all your help. I still haven't got there yet though :) Import71 says that I do not have permission to save (to anywhere it seems) which is odd...this is my laptop. ArcTools 8x in Catalog sys that no spaces can be in the file name....and there are none!

I will attempt this again tomorrow.

Thanks!

#11
Nick H

Nick H

    Legendary Contributor

  • Validated Member
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male
  • Location:Caversham, Reading, England.
  • United Kingdom

I still haven't got there yet though...

As a last resort if all else fails you might care to try 'ogr2ogr' from FWtools:

ogr2ogr -f "ESRI Shapefile" glac_peaks.shp glac_peaks.e00

This works here.

http://confound.me.u.../glac_peaks.zip

Regards, N.
Caversham, Reading, England.

#12
Bryan Swindell

Bryan Swindell

    Contributor

  • Validated Member
  • PipPip
  • 42 posts
  • Gender:Male
  • Location:Montana
  • United States

Thanks for all your help. I still haven't got there yet though :) Import71 says that I do not have permission to save (to anywhere it seems) which is odd...this is my laptop. ArcTools 8x in Catalog sys that no spaces can be in the file name....and there are none!

I will attempt this again tomorrow.

Thanks!


Before going the ArcTools 8x route, rename the .e00 file to 8 characters, and copy it to something like C:/temp/ and then write back to that directory. It took me a few tries to get this to work too - but now it works every time. Much better than the Import 71 tool.

#13
pfyfield

pfyfield

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 100 posts
  • Gender:Male
  • Location:Portland, Oregon
  • United States

E00 files are also called interchange files. There is an "Import from interchange file" tool in the toolbox under Coverage Tools (if you have ArcInfo). You can use this to make a coverage, then make a shapefile from that.
Paul Fyfield
Cartographer, Bureau of Land Management
Oregon State Office
Portland, Oregon
pfyfield@blm.gov




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->