Jump to content

 
Photo

Help w/ Scaling in QGIS for .SHP & raster data from Natural Earth

- - - - -

  • Please log in to reply
5 replies to this topic

#1
619

619

    Newbie

  • Validated Member
  • Pip
  • 3 posts
  • United States

Hi,

I am a new QGIS user having a problem getting Shapefile and Raster data from Natural Earth to properly work together. I think my problem has a simple solution.

I am using a 1:10m Shapefile along with 1:10m Raster imagery from Natural Earth. When I open up these two files in QGIS the background raster imagery is displayed at a size much larger scale than the Shapefile data. See attachment which provides a screenshot - you can see the Shapefile data in the upper left hand corner of the Raster imagery. The Shapefile and Raster imagery data are from the same Natural Earth data set (1:10m) and should work together and appear at the same scale.

I have looked through QGIS to make changes to the rendering and other settings but I can not fix the problem.

Any suggestions on what settings in QGIS I need to adjust in order to get the Shapefile and Raster imagery to align or scale correctly?

Thanks

Using QGIS 1.4.0 on Windows XP SP3

Attached Files



#2
Darren Cope

Darren Cope

    Contributor

  • Validated Member
  • PipPip
  • 12 posts
  • Canada

Make sure that the coordinate systems are properly defined for both layers (check the "general" tab under layer properties). Then enable on-the-fly CRS Transformation (very far bottom right corner) and pick the coordinate system of one of your layers.

That should do it! If one of the layers is not defined, or incorrectly defined, you can over-ride it under the "general" tab using the "Specify CRS" option.

Chers,

Darren

Hi,

I am a new QGIS user having a problem getting Shapefile and Raster data from Natural Earth to properly work together. I think my problem has a simple solution.

I am using a 1:10m Shapefile along with 1:10m Raster imagery from Natural Earth. When I open up these two files in QGIS the background raster imagery is displayed at a size much larger scale than the Shapefile data. See attachment which provides a screenshot - you can see the Shapefile data in the upper left hand corner of the Raster imagery. The Shapefile and Raster imagery data are from the same Natural Earth data set (1:10m) and should work together and appear at the same scale.

I have looked through QGIS to make changes to the rendering and other settings but I can not fix the problem.

Any suggestions on what settings in QGIS I need to adjust in order to get the Shapefile and Raster imagery to align or scale correctly?

Thanks

Using QGIS 1.4.0 on Windows XP SP3



#3
619

619

    Newbie

  • Validated Member
  • Pip
  • 3 posts
  • United States

Make sure that the coordinate systems are properly defined for both layers (check the "general" tab under layer properties). Then enable on-the-fly CRS Transformation (very far bottom right corner) and pick the coordinate system of one of your layers.

That should do it! If one of the layers is not defined, or incorrectly defined, you can over-ride it under the "general" tab using the "Specify CRS" option.

Chers,

Darren

Hi,

I am a new QGIS user having a problem getting Shapefile and Raster data from Natural Earth to properly work together. I think my problem has a simple solution.

I am using a 1:10m Shapefile along with 1:10m Raster imagery from Natural Earth. When I open up these two files in QGIS the background raster imagery is displayed at a size much larger scale than the Shapefile data. See attachment which provides a screenshot - you can see the Shapefile data in the upper left hand corner of the Raster imagery. The Shapefile and Raster imagery data are from the same Natural Earth data set (1:10m) and should work together and appear at the same scale.

I have looked through QGIS to make changes to the rendering and other settings but I can not fix the problem.

Any suggestions on what settings in QGIS I need to adjust in order to get the Shapefile and Raster imagery to align or scale correctly?

Thanks

Using QGIS 1.4.0 on Windows XP SP3



#4
619

619

    Newbie

  • Validated Member
  • Pip
  • 3 posts
  • United States

Hi Darren,

Thanks for your reply. I made sure both layers are both defined with the same coordinate system - WGS 84 - but that did not fix the problem. I still have the same issue. Any other ideas?

Thanks



Make sure that the coordinate systems are properly defined for both layers (check the "general" tab under layer properties). Then enable on-the-fly CRS Transformation (very far bottom right corner) and pick the coordinate system of one of your layers.

That should do it! If one of the layers is not defined, or incorrectly defined, you can over-ride it under the "general" tab using the "Specify CRS" option.

Chers,

Darren

Hi,

I am a new QGIS user having a problem getting Shapefile and Raster data from Natural Earth to properly work together. I think my problem has a simple solution.

I am using a 1:10m Shapefile along with 1:10m Raster imagery from Natural Earth. When I open up these two files in QGIS the background raster imagery is displayed at a size much larger scale than the Shapefile data. See attachment which provides a screenshot - you can see the Shapefile data in the upper left hand corner of the Raster imagery. The Shapefile and Raster imagery data are from the same Natural Earth data set (1:10m) and should work together and appear at the same scale.

I have looked through QGIS to make changes to the rendering and other settings but I can not fix the problem.

Any suggestions on what settings in QGIS I need to adjust in order to get the Shapefile and Raster imagery to align or scale correctly?

Thanks

Using QGIS 1.4.0 on Windows XP SP3



#5
Darren Cope

Darren Cope

    Contributor

  • Validated Member
  • PipPip
  • 12 posts
  • Canada

You'll need to ensure that the layers are defined as what they actually are, don't just make them the same. Then, you'll need to enable the On-The-Fly Transformation and QGIS will take care of the rest. You should be able to find the actual projection/coordinate system info in the metadata that came with the files.

Cheers,

Darren


Hi Darren,

Thanks for your reply. I made sure both layers are both defined with the same coordinate system - WGS 84 - but that did not fix the problem. I still have the same issue. Any other ideas?

Thanks



Make sure that the coordinate systems are properly defined for both layers (check the "general" tab under layer properties). Then enable on-the-fly CRS Transformation (very far bottom right corner) and pick the coordinate system of one of your layers.

That should do it! If one of the layers is not defined, or incorrectly defined, you can over-ride it under the "general" tab using the "Specify CRS" option.

Chers,

Darren

Hi,

I am a new QGIS user having a problem getting Shapefile and Raster data from Natural Earth to properly work together. I think my problem has a simple solution.

I am using a 1:10m Shapefile along with 1:10m Raster imagery from Natural Earth. When I open up these two files in QGIS the background raster imagery is displayed at a size much larger scale than the Shapefile data. See attachment which provides a screenshot - you can see the Shapefile data in the upper left hand corner of the Raster imagery. The Shapefile and Raster imagery data are from the same Natural Earth data set (1:10m) and should work together and appear at the same scale.

I have looked through QGIS to make changes to the rendering and other settings but I can not fix the problem.

Any suggestions on what settings in QGIS I need to adjust in order to get the Shapefile and Raster imagery to align or scale correctly?

Thanks

Using QGIS 1.4.0 on Windows XP SP3



#6
Nick H

Nick H

    Legendary Contributor

  • Validated Member
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male
  • Location:Caversham, Reading, England.
  • United Kingdom

...I made sure both layers are both defined with the same coordinate system - WGS 84 - but that did not fix the problem. I still have the same issue. Any other ideas?

Looking at the screen shot you posted, it looks as if the coordinates shown are pixel coordinates for the raster image. This probably means that QGIS is ignoring the TFW world file for some reason. Check the TFW file, its extension should be *.tfw. I recently downloaded a Natural Earth raster and for some reason it had a world file in the format 'imagename.tfw.txt'. This wasn't recognised by QGIS, of course.

Regards, N.
Caversham, Reading, England.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->