Jump to content

 
Photo

Road Symbols

- - - - -

  • Please log in to reply
2 replies to this topic

#1
Robert2009

Robert2009

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 122 posts
  • Gender:Male
  • Location:Las Cruces, NM
  • United States

Hello,

I am trying to figure it out what is the best way to save the road symbols. What I do is set it up in the labels along with the
road numbers and then convert it to annotation. But the problem is when I zoom in, the road symbol is bigger than
the road. For example, I zoom in to 1:24,000 and the road symbols should be smaller but it show bigger. How do I fix it ?
Any suggest ?

Thanks,
Robert

:)

#2
jrat

jrat

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 143 posts
  • Gender:Male
  • Location:Hagerstown, MD
  • United States

Once you convert the labels to annotation they will continue to be drawn relative to the reference scale of the annotation. As you zoom in the annotation is continuing to be drawn against the original scale.

You have a couple of options. Leave them as labels and they will be redrawn as you zoom in/out. Assuming you are using ESRI software you will not have total control over how the labels are positioned using this method. If you are not hung up on placement but are just want to save the lable format, you can save the format as a lable style. You are then able to load that style into future maps.

If you want more control and labels that look right at different scales, you will probably have to create multiple annotation layers. Create each layer at various scales and then set their view extent for a scale range that they look appropriate. Then as you zoom in and out the layers will turn themselves on and off.

hope this helps

#3
aehler

aehler

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Canada

Within the Dataframe properties, you have some options with the Annotation Groups. One of the options is "scale". When the labels are converted to annotation they are automatically given a scale which matches the current scale of the layout or dataframe. You can set the annotation group scale to "none" which would make the symbols smaller the more zoomed in you are and larger the more zoomed out you are. Or choose an appropriate scale that works for the map you're working on and the symbol size will remain the same no matter what zoom level.

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->