Jump to content

 
Photo

ArcToolbox - error message

- - - - -

  • Please log in to reply
1 reply to this topic

#1
Brandon Tourtelotte

Brandon Tourtelotte

    Contributor

  • Validated Member
  • PipPip
  • 37 posts
  • Gender:Male
  • Location:Minneapolis, MN
  • Interests:Cartography<br />International GIS Datasets<br />Jazz (and all other kinds of music)<br />Introspection<br />Networking<br />Engaging personalities<br />Challenging thinkers
  • United States

Wondering if anyone has ever had the type of error message I've been getting when using ArcToolbox in ArcGIS 9.2.
Under the Analysis tools > Overlay > Identity or Intersect ... when I use any of these sorts of tools, I get an error message saying:
"Unexpected TopoEngine Error
Number of shapes does not match the number of table records
Failed to execute" etc etc

Has anyone ever seen this sort of error - any ideas?

It works fine on other machines, even processing on the same Shp files on a network. But for some reason from my machine I get this.

I tried creating a couple of new simple shp files so that I KNOW the shapes and # of table records are the same, and still the same result. I also tried completely re-installing the software to reset all variables and settings, still no luck.
Brandon Tourtelotte
East View Cartographic, Inc.
Minneapolis, MN

#2
BioGeoMan

BioGeoMan

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 188 posts
  • Gender:Male
  • Location:Albuquerque, NM
  • United States

Hello Brandon,

This is a common error in 9.1 and 9.2. It usually involves checking the geometry of your shapefiles or is related to some sort of memory limitation on your workstation. Go here: http://forums.esri.c...p...85&t=208189 and take a look at some of the proposed solutions.

Good luck!
M.

Michael Scisco

BioGeoCreations
Albuquerque, NM

505-603-3636
biogeocreations.com





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->