Jump to content

 
Photo

ARCGIS SERVER labelling problem

- - - - -

  • Please log in to reply
1 reply to this topic

#1
vipul soni

vipul soni

    Newbie

  • New Member
  • Pip
  • 1 posts
  • India

Dear Friends,

i need help for a very peculiar kind of problem for which i have searched all possible forums from esri related arcgis server.though very less information is posted in them.

the problem i am facing is that my MXD has its labelling for the layers set to ON.
but in ARCGIS server when i pan the map the labels keep on doubling up. i.e first laels drawn for some particular map pan are not removed in the next map pan and thus in some couple of minutes the user may find 3 or 4 labels for one polygon itself. thus creating a haphazzard view of the map iteslf..

i have tried all the possible techniques in arcgis desktop related to labelling ...like using Maplex extension etc. and setting the options to remove duplicate labels.but the mxd shows no problem in labeling in arcgis desktop until used in the arcgis server.

any help in this regards is appreciated. :o

thanks,

vipul

#2
klacefield

klacefield

    Contributor

  • Validated Member
  • PipPip
  • 29 posts
  • Gender:Male
  • Location:Santa Rosa, CA
  • United States

Vipul,

It sounds like there is a refresh issue with the map. What version of ArcGIS Server are you using and is it out of the box functionality or have you made any modifications? Another question that comes to my mind is, are you using caching/tiling or not?

My group is in the process of programming an ArcGIS Server application and so I can ask around and try to get a solution for you.

-Kevin
Kevin Lacefield, GIS Programmer Analyst
County of Sonoma
Information Systems Department - GIS Central




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->