Jump to content

 
Photo

ArcMap to Illustrator - jagged lines

- - - - -

  • Please log in to reply
16 replies to this topic

#1
cc harper

cc harper

    Newbie

  • Validated Member
  • Pip
  • 5 posts
  • United States

I have a different problem from this one but still within "ArcMap to Illustrator problems" topic. Maybe it's best to post as a new topic instead. Let me know if posting here is the wrong approach. Thank you!

Software: ArcView 9.1 and AI 10
Content: 6 sq mi vector data of building footprints and curb/gutter
Problem: After exporting either to AI or PDF from ArcView, I get unclean, jagged lines in the resulting Illustrator document. I've tried different .dpi and a few other settings. Does anyone know what could be causing this?

#2
ELeFevre

ELeFevre

    Hall of Fame

  • Associate Admin
  • PipPipPipPipPipPipPip
  • 1,049 posts
  • Gender:Male
  • Location:Louisville, Colorado USA
  • Interests:Cartography, musical instruments, reading, hiking, craft beer
  • United States

I have a different problem from this one but still within "ArcMap to Illustrator problems" topic. Maybe it's best to post as a new topic instead. Let me know if posting here is the wrong approach. Thank you!

Software: ArcView 9.1 and AI 10
Content: 6 sq mi vector data of building footprints and curb/gutter
Problem: After exporting either to AI or PDF from ArcView, I get unclean, jagged lines in the resulting Illustrator document. I've tried different .dpi and a few other settings. Does anyone know what could be causing this?



You're not alone here. I haven't been able to get a "jagged free" Illustrator export since upgrading to 9.1. The results seem to have gotten even worse since 9.2. Not sure what's going on here. I think it's a bug. All of the files I've exported do not include rasters, marker symbols, or transparencies, et cetera. If anyone is getting clean vector "pre 9.1" Illustrator export results in 9.1 or 9.2 please share your export settings with us.



#3
Hans van der Maarel

Hans van der Maarel

    CartoTalk Editor-in-Chief

  • Admin
  • PipPipPipPipPipPipPip
  • 3,882 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Cartography, GIS, history, popular science, music.
  • Netherlands

I have a different problem from this one but still within "ArcMap to Illustrator problems" topic. Maybe it's best to post as a new topic instead. Let me know if posting here is the wrong approach. Thank you!


I've split it off into a new topic.
Hans van der Maarel - Cartotalk Editor
Red Geographics
Email: hans@redgeographics.com / Twitter: @redgeographics

#4
frax

frax

    Hall of Fame

  • Associate Admin
  • PipPipPipPipPipPipPip
  • 2,309 posts
  • Gender:Male
  • Location:Stockholm, Sweden
  • Interests:music, hiking, friends, nature, photography, traveling. and maps!
  • Sweden

Here is what I have experienced - if you set a "lowerish" dpi value, it will try to generalize the data in the export process, and that is primarily making all vector lines as 45 deg segments. This is what I have seen, in ArcGIS 9.1

I always leave the export at an unrealisticly high level, some 3500 dpi or something, to avoid that generalization.
Hugo Ahlenius
Nordpil - custom maps and GIS
http://nordpil.com/
Twitter

#5
Mike H

Mike H

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 168 posts
  • Location:State College, PA
  • United States

I always leave the export at an unrealisticly high level, some 3500 dpi or something, to avoid that generalization.



Exactly - it's misleading (or counter-intuitive) because we would expect 300 dpi to be sufficient. The max is 10,000. Try exporting one layer at 10,000 and see if the jagginess dissapears, then back it down to an acceptable level for reasonable file size.

m.
Michael Hermann
mike [at] purplelizard.com


www.purplelizard.com

#6
Cartisan Maps

Cartisan Maps

    Contributor

  • Validated Member
  • PipPip
  • 24 posts
  • Location:Washington, DC
  • United States

I'm running 9.1, exporting at 1200 dpi and I don't seem to be having that problem. I did notice the issue at 300 and 600.
__________________

Cartisan Maps
www.cartisan.com
202-355-5001
__________________

#7
cc harper

cc harper

    Newbie

  • Validated Member
  • Pip
  • 5 posts
  • United States

Thank you for your responses; all contributions were reassuring and helpful. In case you're interested in the jagged lines issue results:

A 10,000 dpi export from 9.1 was perfect, 6000 sufficient, and below 4000 unacceptable. The resulting AI file sizes aren't much different and are typical file sizes for my work: 10,000 dpi = 4.7M, 6000 dpi = 4.4M, and 4000 dpi = 4.3M. These are sizes after converting the original export from AI 3.0-3.2 to AI 10 compatiblity.

Thank you!
Cindy Harper

#8
Martin Gamache

Martin Gamache

    Ultimate Contributor

  • Associate Admin
  • PipPipPipPipPipPip
  • 980 posts
  • Gender:Male
  • Location:Washington DC
  • Interests:History of Topographic Cartography
    Topographic Mapping
    History of Relief Depiction
    Thematic Cartography
    Demographic Cartography
    Cartographic techniques, methods, and tools
    Orienteering
    Panoramic & Kite Photography
  • United States

I'm running 9.1, exporting at 1200 dpi and I don't seem to be having that problem. I did notice the issue at 300 and 600.



I try to keep it at multiples of 72dpi.

#9
Mike H

Mike H

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 168 posts
  • Location:State College, PA
  • United States

A 10,000 dpi export from 9.1 was perfect, 6000 sufficient, and below 4000 unacceptable.



Glad that helped - I find the export number and results are data-dependent. Dependent on what, that remains unknown! But the approach you used is easiest to at least know how good it can look, and then make your decision. Another trick that drops file size is to cut and paste the layer to a new file in illy, I've seen files size cut in half or more - they carry some extra overhead within the .ai export that remains when you open them initially. Not sure why but a quick cut and paste drops the overhead.

m.
Michael Hermann
mike [at] purplelizard.com


www.purplelizard.com

#10
Charlie Frye

Charlie Frye

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 112 posts
  • Gender:Male
  • Location:Redlands, CA
  • Interests:Base map design/data model, political/election maps; use of historical maps for modern GIS analysis
  • United States

One of the reasons some of you are seeing differences in which DPI works for you is that the density of vertexes in your data at the scale you're using will affect this issue. If you're using very detailed data at small scales, you'll see this problem in spades, so to speak. If you're using appropriately generalized data, then you may not see the problem at all.

Another contributing cause is lines that contain extreme direction changes, say 170 degrees at a given vertex. Further, the wider the line symbol you choose for that line, the more likely you'll see the problem.

Basically wide line symbols on very short segments that change direction signficantly are the root causes.

The problem is in the Microsoft Windows GDI rendering engine we use. We are working on a rendering engine to replace our use of Windows GDI; and this is one of the problems we are addressing. Most prominent graphics software makers, e.g., Adobe, and Corel have already done this. Our new rendering engine will be released in the next major release, i.e., not a dot release.
Charlie Frye
Chief Cartographer
Software Products Department
ESRI, Redlands, California

#11
merft

merft

    Key Contributor

  • Validated Member
  • PipPipPip
  • 86 posts
  • Location:Colorado
  • United States

The problem is that you have a transparent or raster layer above your vector line work. Resolution is not an issue here.

To export to Illustrator from ArcMap:
  • Import your data and create your layout to the size you plan to use.
  • Make sure you have NO transparency settings set on ANY vector layer
  • Turn off all raster layers
  • Make note of your layout dimensions (i.e., 24x36 inches)
  • Export your vector line work into Illustrator format (.ai)
  • Turn off all vector layers and turn on your raster layers one by one
  • Export each raster layer as its out TIF/JPG or whatever raster format you desire
  • Open you AI file in Illustrator
  • Change the artboard dimensions (usually defaults to 18x18 inches) to the actually size of the layout (i.e. 24x36 inches)
  • Create a new layer for each raster image and place each raster image on its own layer
This process give me true editable vector line work and fairly clean rasters all layered in an AI file. The only difficultly is with labelling. ArcMap still puts all labels in one layer. So if you need to separate labelling by layer, you will need to export each raster layer individually and recompile the AI file manually.

-Tom

#12
Charlie Frye

Charlie Frye

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 112 posts
  • Gender:Male
  • Location:Redlands, CA
  • Interests:Base map design/data model, political/election maps; use of historical maps for modern GIS analysis
  • United States

Tom's posting made me think of another reason for rasterization, as layer transparency is just one way to get your map to rasterize. Mainly watch for picture marker symbols, which may be used as markers, or as markers on lines, or in fills, or on lines in fills, or on any of those on text.

If the picture marker symbol is based on a bitmap file (.BMP), rasterization will occur. If the picture marker is based on an enhanced metafile (.EMF), and that .EMF file contains raster elements, the map will rasterize. In both cases rasterization occurs starting in the Table of Contents with the layer that uses the picture marker and all layer below that will get rasterized. If you use such a marker on a graphic element in your dataframe, which draws last, then the whole map rasterizes.

Rasterization whether caused by picture markers or transparency results in a stair-stepped effect, versus the spikey effect of the GDI engine trying to render line symbols. We hear both effects being called jagged, but more often its the latter.
Charlie Frye
Chief Cartographer
Software Products Department
ESRI, Redlands, California

#13
cc harper

cc harper

    Newbie

  • Validated Member
  • Pip
  • 5 posts
  • United States

As far as I can tell, I have only vector layers. Is there a place a raster layer might be hiding? Thanks.

Cindy

#14
Rob

Rob

    Legendary Contributor

  • Moderator
  • PipPipPipPipPip
  • 418 posts
  • Gender:Male
  • Location:Kailua, Hawaii
  • Interests:anything outside.
  • United States

This process give me true editable vector line work and fairly clean rasters all layered in an AI file. The only difficultly is with labelling. ArcMap still puts all labels in one layer. So if you need to separate labelling by layer, you will need to export each raster layer individually and recompile the AI file manually.

-Tom


Tom, that's pretty much the same workflow I follow. For the labeling, I make different labels wacky colors, like orange, pink, green, and then use the select by color function in AI to sperate.

I am always really displeased with the raster export quality for Arc. It always looks like it has been down sampled, even if I use super high resolutions. Does anyone know any tricks about this, or is it just an evil ploy to make us all need to buy the arc press extension?

rob

#15
peanut

peanut

    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 138 posts
  • Location:Austin, TX
  • United States

I am always really displeased with the raster export quality for Arc. It always looks like it has been down sampled, even if I use super high resolutions. Does anyone know any tricks about this, or is it just an evil ploy to make us all need to buy the arc press extension?


I usually get decent raster output when I export to PDF and I set the Output Image Qualty (Resample Ratio) to Best. Unfortunately for larger exports setting the image quality to best at a high resolution doesn't work on lower end machines.

Rich




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->