Jump to content

 
Photo

ArcMap export oddity

- - - - -

  • Please log in to reply
6 replies to this topic

#1
frax

frax

    Hall of Fame

  • Associate Admin
  • PipPipPipPipPipPipPip
  • 2,303 posts
  • Gender:Male
  • Location:Stockholm, Sweden
  • Interests:music, hiking, friends, nature, photography, traveling. and maps!
  • Sweden

Has anyone seen this? I have seen it now and then, and only for cases when I export huge polygons. What you see here is land, no further - so except for islands and denmark, it is just one huge polygons. I have cranked up the resolution for exports high (to not get any unwanted generalization) and I have increased the max number of nodes in polygons to extreme amounts (to avoid unwanted banding). Software is ArcMap 9.1 and Illy CS2.

Before export, looks nice:
Posted Image

Importing into Illy, this is outline mode, since the polys don't get their correct fill, since one node is not closed properly...
Posted Image

It could very well be Illy that is doing something funny, as it is a bezier curve (the one on the very top) and not a straight path (ArcMap only exported straight lines in this case)

I can just add that it works ok when I export is an eps file...
Hugo Ahlenius
Nordpil - custom maps and GIS
http://nordpil.com/
Twitter

#2
Hans van der Maarel

Hans van der Maarel

    CartoTalk Editor-in-Chief

  • Admin
  • PipPipPipPipPipPipPip
  • 3,868 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Cartography, GIS, history, popular science, music.
  • Netherlands

IIRC, Illustrator has a limit on the number of points in a polygon. Not sure exactly what it is though. It looks like you're running into this problem here.
Hans van der Maarel - Cartotalk Editor
Red Geographics
Email: hans@redgeographics.com / Twitter: @redgeographics

#3
frax

frax

    Hall of Fame

  • Associate Admin
  • PipPipPipPipPipPipPip
  • 2,303 posts
  • Gender:Male
  • Location:Stockholm, Sweden
  • Interests:music, hiking, friends, nature, photography, traveling. and maps!
  • Sweden

that might be it - I noticed that I couldn't merge the points manually to create a super-polygon - until I simplified the paths.

And the eps file was not the right track, it had banding.
Hugo Ahlenius
Nordpil - custom maps and GIS
http://nordpil.com/
Twitter

#4
CHART

CHART

    Chart

  • Validated Member
  • PipPipPipPipPip
  • 358 posts
  • No Country Selected

I believe the Illy limit is 32000 object/node (not sure if CS2 has that limit).

Also if you have MapPublisher it solves that problem when importing by closing the polygons without damaging the overall look of the polygon.
Chart

#5
david17tym

david17tym

    Key Contributor

  • Validated Member
  • PipPipPip
  • 99 posts
  • Gender:Male
  • Location:North Wales
  • United Kingdom

FYI, the 'banding' or dicing can be turned off before you export to illy, pdf etc.

assign the following code to a button to turn dicing off:

Dim pGeometryEnv As IGeometryEnvironment3
Set pGeometryEnv = New GeometryEnvironment
pGeometryEnv.DicingEnabled = False

and to turn back on (always worth remembering before you plot):

Dim pGeometryEnv As IGeometryEnvironment3
Set pGeometryEnv = New GeometryEnvironment
pGeometryEnv.DicingEnabled = True

hope this helps,

dave

#6
MapMedia

MapMedia

    Hall of Fame

  • Validated Member
  • PipPipPipPipPipPipPip
  • 1,029 posts
  • Gender:Male
  • Location:Davis, California
  • United States

Have you changed the maximum # of allowable vertices in ArcMap's AI export using resedit?

There is an ESRI tech article on how to do this if you search the knowledge base.

#7
Matthew Hampton

Matthew Hampton

    Hall of Fame

  • Moderator
  • PipPipPipPipPipPipPip
  • 1,303 posts
  • Gender:Male
  • Location:Portland, Oregon
  • Interests:Playing in the mountains and rivers.
  • United States

You could also simplify the poly in Arc before exporting. I think the tool is on the advanced editing toolbar.

co-cartographic creator of boringmaps.com





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

-->