Jump to content


Exporting ArcGIS to Illustrator - Problems with images becoming strips or non-usable layers

- - - - - illustror export arcGIS layers

  • Please log in to reply
2 replies to this topic




  • New Member
  • Pip
  • 1 posts
  • United States

Hi There,
I'm not a designer; I'm a managing editor, but I need some advice.  We often receive ArcGIS files for publication.  We generally ask authors to try to export the files into Illustrator files whenever possible, for our designer's sake.
We've had similar problems lately where some of the files sent to us are editable — the legend and the place names — but the rest of files are a pictures cut into strips.  So our designer can't edit the rest of the file — the rail lines, the population areas, etc.  
I'll attach a screenshot where you can see some of the strips pulled apart.
Any ideas of what settings we should be using to make the files more usable?  Or should we be exporting in a different way?  This seems to happen often with ArcGIS files in particular.

Attached Thumbnails

  • Map-Strips.png




  • Validated Member
  • PipPip
  • 42 posts
  • Gender:Male
  • United States



This happens when ArcMap renders a portion of the export as raster or when the illustration is too big (too many vertices, off the top of my head, I think ArcMap exports each object with a maximum of ~8000 vertices, but there is a fix to this).  ESRI calls this effect "dicing".


Problem 1:  ArcMap converts vector layers to raster.  In your case, it looks like a portion of the map is being converted (or is) a raster.  During the Illustrator export process of ArcMap, layers are exported starting from the top layer and moving to the bottom layer (not sure this is exactly what happens, but for the purpose of explaining this bug, it's easier to think of it this way).  When ArcMap detects a raster layer, or a layer with raster effects, such as transparency, ArcMap exports that layer as a raster.  ArcMap also combines every single layer below that raster layer into one raster image.  The stripping occurs because ArcMap is combining multiple layers on the fly.  To solve this problem, have the geospatial technician ensure there are no raster effects on any of the layers.  If there are raster layers, have him/her turn those layers off for the export to Illustrator and then export just those raster layers as a high-resolution TIFF.  The vector layers can then be placed on top of the raster TIFF in Illustrator (and the TIFF will be one solid image instead of strips).


Problem 2:  ArcMap break up vector layers into strips.  If problem 1 is not your issue, or you encounter ArcMap's other export "feature", this is what is going on.  When ArcMap exports vectors, there is a setting that limits the maximum number of vertices per object during the export.  This is by design because Illustrator (many versions ago) had a rather small object vertices limit.  In ArcMap 10.x, the default maximum is 8000, which is far lower than Illustrator CS6/CC can handle.  I researched the actual limit for Illustrator CS6/CC for quite a while earlier this year with success, but in my own trials, I found that it could successfully handle in excess of 32,000 vertices per object.  To change the vertex limit, follow the steps here, copied below:


  1. Start Windows Explorer and navigate to C:\Program Files\ArcGIS\Utilities and double-click on AdvancedArcMapSettings.exe to start the Advanced ArcMap Settings.
  2. Click the Print\Export tab.
  3. To modify the export polygon vertex limits, select the value in the edit box next to the desired format and enter a new maximum number of vertices. For example, to reset the maximum number of vertices from the Adobe Illustrator (AI), export format to 10,000 vertices, delete the AI value, which by default is set to 8000, and enter 10000. (esri recommends 10,000, but I have found 32,000 to work without issue)
  4. Click Apply and click Close.

    The utility never writes anything to the registry unless the Apply button is pressed, and then, it only writes settings for those values that have changed.
Hopefully this helps.  Let me know if you have more issues with this.

  • oombaca likes this



    Master Contributor

  • Validated Member
  • PipPipPipPip
  • 211 posts
  • Gender:Female
  • Location:Olten, Switzerland
  • Interests:geology, GIS, cartography, famlily, reading, cooking, travelling, gardening
  • Switzerland

Yes, ArcGIS cannot deal with transparencies and the like for export (same as Illustrator when exporting to dxf or dwg, by the way). It packs that layer and anything below it (in the table of content) into one raster layer. And this raster always comes in stripes...

My workaround is to ensure that there is absolutely no transparency in the ArcGIS map before exporting. This may cause certain parts of the map not to like you want, e.g. solid colour polygons instead of semitransparent ones which show the background image underneath. Just use Illustrator to change those back to the desired transparency.


Obviously this works well if all done by the same person or by people working really closely together (because both need to understand what's happening). In case of an external contractor producing the Illustrator export it may be much harder to explain to him exactly what you need...


Hope this helps.



Also tagged with one or more of these keywords: illustror, export, arcGIS, layers

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users